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Introduction 
 
This workshop will give you an opportunity to use further optimization techniques from within the 
Graphical User Interface (GUI) to reduce the peak stresses within a Part. The results will be 
viewed in Abaqus/CAE. 

 

Preliminaries 
Start a new session of Abaqus/CAE using the following command: 

abaqus cae  

where abaqus is the command used to run Abaqus. 

In the Start Session dialog box, underneath Create Model Database, click With 
Standard/Explicit Model. 

 
 

To save the model database, select File→Save As from the main menu bar and type the 
file name LugOptShape in the Save Model Database As dialog box. Click OK. 

The .cae extension is added to the file name automatically. 

 

Creating a part 

In this section you will import the .inp file of the lug you created during the Tosca Topology 
workshop, as a three-dimensional, deformable solid body. 
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1. Abaqus/CAE automatically loads the Part module. Any other module can be accessed 
from the Module list located in the context bar. 

 

 

2. From the main menu bar, select File > Import > Model to import a new model. Change 
the File Filter dropdown to Abaqus Input File (*.inp,*.pes). Navigate to the directory 
where you saved file ‘optimize_lug_mm_surface.inp’ in workshop 2 and select the file. 
Click OK to import the file. 

3. Abaqus/CAE automatically loads the new model (optimize_lug_mm_surface) into the 
Assembly module. 

 
At present the part is meshed with triangular shell elements. Navigate to the Mesh module and 

use the query tool  to query any Element in the model. The Element type and connectivity is 

displayed in the message area at the bottom of the GUI. You will now convert this surface 

triangular mesh to a continuum solid tetrahedral mesh. 

1. First select the Edit Mesh icon  change the category to Mesh and select Convert tri 

to tet. Abaqus/CAE knows that there is only one volume which is completely enclosed 

with shells and so simply asks if it is OK to mesh the part with tets. Answer yes and then 

use the query tool again to query one of the elements. This will confirm that the surface 

tri mesh has been converted to linear tetrahedral elements. In Abaqus this type of 

element (C3D4) should not be used in regions of concern, and so you will now convert 

them to higher order (quadrilateral) tetrahedral elements. 

2. From the main menu select Mesh > Element Type and drag pick the entire structure for 

the region to be assigned element types. Click mouse button 2 or done to complete the 

pick and then select Quadratic on the Element Type dialogue box. Click OK to complete 

the operation. Check the new element type using the query tool. 

Save the Abaqus/CAE database. 
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Creating a material definition 
You will now create a single linear elastic material with a Young’s modulus of 200103 MPa and 
Poisson’s ratio of 0.3. 

To define a material: 

1. In the Model Tree, double-click Materials to create a new material in the model 
optimize_lug_mm_surface. 

Abaqus/CAE switches to the Property module, and the material editor appears.  

2. In the Edit Material dialog box, name the material steel. Notice the various options 
available in this dialog box. 

 

 

3. From the material editor’s menu bar, select MechanicalElasticityElastic. 

Abaqus/CAE displays the Elastic data form. 

4. Enter a value of 200.E3 for Young’s modulus and a value of 0.3 for Poisson’s ratio in the 
respective fields. Use [Tab] to move between cells, or use the mouse to select a cell for 
data entry. 

5. Click OK to exit the material editor. 
 

Defining and assigning section properties 
Next, you will create a homogeneous solid section and assign it to the optimized lug part. The 

section will refer to the material steel that you just created. 

To define the homogeneous solid section: 

1. In the Model Tree, double-click Sections to create a new section in the model 
optimize_lug_mm_surface. 

The Create Section dialog box appears. 

2. In the Create Section dialog box: 

a. Name the section solid_section. 
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b. Accept the default category Solid and the default type Homogeneous. 

c. Click Continue. 

The solid section editor appears. 

3. In the Edit Section dialog box: 

d. Accept the default selection of steel for the Material associated with the section. 

e. Accept the default value of 1 for Plane stress/strain thickness. 

Note: For three-dimensional solid geometry, this value is not used. It is only 
relevant for two-dimensional geometry. 

f. Click OK. 

To assign the section definition to the optimized lug model: 

1. In the Model Tree, expand the branch under Model optimize_lug_mm_surface for the 
part PART-1 (click the “+” symbol to expand the Parts container and then click the “+” 
symbol next to the part PART-1). 

2. Double-click Section Assignments to assign a section to the part PART-1. 

Abaqus/CAE displays prompts in the prompt area to guide you through the procedure. 

3. Drag pick to select all elements in the entire part as the region to which the section will 
be assigned. 

4. Click mouse button 2 in the viewport or click Done in the prompt area to accept the 
selected elements. 

The section assignment editor appears. 

5. In the Edit Section Assignment dialog box, accept the default selection of 
solid_section as the section definition, and click OK. 

Abaqus/CAE colors the lug green to indicate that the section has been assigned. 

Save the Abaqus/CAE database. 

Assembling the model 
The assembly for this analysis was done during the import of the model. 

Configuring the analysis 
In this simulation we are interested in the static response of the optimized lug to the same 

pressure load (50 N/mm2) applied over one half of the hole surface. This is a single event, so 

only a single analysis step is needed for the simulation. Consequently, this model will consist of 

two steps: 

 An initial step, in which you will apply a boundary condition that constrains one end of 
the lug.  

 A general, static analysis step, in which you will apply a pressure load to the bottom face 
of the hole. 

Abaqus/CAE generates the initial step automatically, but you must create the analysis step 

yourself.  
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To create a general, static analysis step: 

1. In the Model Tree, double-click Steps to create a new step in the model 
optimize_lug_mm_surface.  

Abaqus/CAE switches to the Step module, and the Create Step dialog box appears. 

2. In the Create Step dialog box: 

a. Name the step Step-1. 

b. From the list of available general procedures in the Create Step dialog box, 
select Static, General if it is not already selected. 

c. Click Continue. 

The step editor appears. 

3. In the Edit Step dialog box: 

a. In the Description field of the Basic tabbed page, enter Load the new design. 

b. Click the Incrementation tab, and accept the value of 1 that appears in the 
Initial text field. 

c. Click the Other tab to see its contents; you can accept the default values 
provided for the step. 

d. Click OK to create the step and to exit the step editor. 

Applying a boundary condition and a load to the model 

Next, you will define the boundary condition and loading that will be active during Step-1. 

To apply boundary conditions to the rectangular end of the lug: 

1. In the Model Tree, double-click BCs to create a new boundary condition in the model 
optimize_lug_mm_surface.  

Abaqus/CAE switches to the Load module, and the Create Boundary Condition dialog 
box appears. 

2. In the Create Boundary Condition dialog box: 

g. Name the boundary condition Fixed. 

h. Select Initial as the step in which the boundary condition will be activated. 

i. In the Category list, accept the default category selection Mechanical. 

j. In the Types for Selected Step list, select Symmetry/Antisymmetry/Encastre 
as the type. 

k. Click Continue. 

Abaqus/CAE displays prompts in the prompt area to guide you through the 
procedure. The face at the rectangular end of the lug will be fixed, as before. 
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3. Abaqus/CAE knows that there is no geometry in the model – just nodes and elements. In 
the dropdown box change the Select regions parameter from individually to by angle 
and accept the default angle between adjacent faces of 20 degrees. Pick any node on 
the end face and the whole face will be selected as shown. Click Done in the prompt 
area to accept the selected geometry. 

The Edit Boundary Condition dialog box appears. When you are defining a boundary 
condition in the initial step, all six degrees of freedom are unconstrained by default. 

4. In the Edit Boundary Condition dialog box: 

a. Toggle on ENCASTRE to fully fix the end of the lug. Abaqus will simply ignore 
the rotational degrees of freedom BCs since they do not exist for solid continuum 
elements. 

b. Click OK to create the boundary condition definition and to exit the editor. 

Abaqus/CAE displays arrows at each node on the selected face to indicate the 
constrained degrees of freedom. 

Save the Abaqus/CAE database. 

To apply a load to the bottom face of the hole: 

1. In the Model Tree, double-click Loads to create a new load in the model 
optimize_lug_mm_surface. 

The Create Load dialog box appears. 

2. In the Create Load dialog box: 

c. Name the load Pressure. 

d. Select Step-1 as the step in which the load will be applied. 

e. In the Category list, accept the default category selection Mechanical. 
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f. In the Types for Selected Step list, select Pressure. 

g. Click Continue. 

Abaqus/CAE displays prompts in the prompt area to guide you through the procedure. 

3. In the prompt area, select by angle to pick element faces. Pick any element in the hole 

and the entire inside surface of the hole will be picked. Then use the  button on the 

view menu to change the view. Turn off the view perspective  and then use ‘ctrl’ drag 
pick to remove the element faces around the top half of the hole. Note that you will have 
to change by angle back to individually in the prompt area to perform the drag pick 
operation. 

 
 

4. Name the pressure surface press and click mouse button 2 in the viewport or click Done 
in the prompt area to indicate that you have finished selecting regions.  

5. In the Edit Load dialog box: 

h. Enter a magnitude of 50 for the load. 

i. Accept the default Amplitude selection (Ramp) and the default Distribution 
(Uniform). 

j. Click OK to create the load definition and to exit the editor. 

Abaqus/CAE displays downward–pointing arrows along the element faces in the hole to 
indicate the load is applied onto the element face. NB a negative pressure would be 
applied away from the element face – as a traction. 

Save the Abaqus/CAE database. 

Creating and submitting an analysis job 
The definition of the model optimize_lug_mm_surface is now complete. Next, you will create 

and submit an analysis job to analyze the model, and then an Optimization job to perform the 

optimization. 
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To create and submit an analysis job: 

1. In the Model Tree, double-click Jobs to create a new analysis job. 

Abaqus/CAE switches to the Job module, and the Create Job dialog box appears. 

2. In the Create Job dialog box, name the job new -lug-analysis and select the model 
optimize_lug_mm_surface. Click Continue. 

The job editor appears. 

3. In the Description field of the Edit Job dialog box, enter Workshop 3. 

4. Click the Parallelization tab and check the box to Use multiple processors. Use the 
up arrow to set the number of processors to 4. 

5. Click the tabs to see the contents of each folder of the job editor and to review the 
default settings. Click OK to accept the default job settings. 

6. From the menu toolbar select Job > Manager. 

The menu for the job manager appears. 

7. From the job manager, select the job new -lug-analysis then select Submit. 

8. As the job runs the status will be shown in the job manager window. Select Monitor to 
follow the status of the job as it runs. Click on each of the tabs to see what is reported 

during/after analysis. 

Viewing the analysis results 
You are now ready to view the results of the analysis in the Visualization module. 

1. In the Model Tree, click mouse button 3 on the job new-lug-analysis and select Results 
from the menu that appears. Abaqus/CAE switches to the Visualization module, opens 
the output database created by the job (new-lug-analysis.odb), and displays the 

undeformed shape of the model. 

2. Click on the Plot Contours on Deformed Shape button  to see a contour plot of the 
field variables. 

3. Select Options > Common from the main menu to change the style of the plot and/or 
the deformation scale factor of the plot. Check the button Free edges to turn off the 
element edges and make the plot a little clearer. Note the deformation scale factor has 
been automatically set. 
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Shape Optimization 
Now you will perform a shape optimization of the lug. The aim will be to reduce the local 
stresses in the cross members. Switch back to the Optimization module. 

Create the Set containing the region to be optimized 

1. From the main menu select Tools > Set > Create. Name the set design_nodes and 
check the type is set to Node. Click continue. 

2. Use the by angle and individually settings and Shift click to add and Ctrl Click to 
remove to select the nodes on the cross members and knuckle joint as shown. Remove 
all nodes that sit on the angle between the sides and the inside surface. Click done to 
create the set. 

 

 
 

Create the Optimization Task 
3. In the model tree under the model optimize_lug_mm_surface double click 

Optimization Tasks. Abaqus/CAE will automatically open the Create Optimization 
Task window. Select Shape optimization and click continue. 

4. Select the set design_nodes for the optimization region and click continue. 

5. Check the box to Freeze boundary condition regions. 

6. Under Mesh Smoothing Region select Specify first layer: (Not Picked) and set the 

number of layers to smooth to 1. Then use the  button to specify the set 
‘design_nodes’ for the first layer. 

7. Specify the Number of node layers adjoining the task region to remain free to 1. 

8. Switch to the Mesh Smoothing Quality tab and change the target mesh quality to 
Medium. 

Create the Design Responses 

9. In the model tree open the Optimization Tasks, then Task-1 by clicking on the + button. 
Then double click Design Responses. Abaqus/CAE will automatically open the Create 
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Design Response window. Name the response DRESP_VM_stress. Accept the default 
Single Term and click continue. 

10. Select Point (nodes) as the design response region type – and the set design_nodes. 

11. Select Stress as the variable, and Mises hypothesis. Change the Operator on values 
in region to Maximum. 

12. Switch to the Steps tab and Specify the Source of values. Click the  button to add a 
model and choose optimize_lug_mm_surface. Click in the Step and Load Case box to 
add Step-1 from the dropdown 

13. .Set the Operator on values across steps and load cases to Maximum value. Then Click 
OK to complete the response. 

14. Create a second Design response called DRESP_Volume. Select the design response 
region type to Body (elements) – then select in viewport all elements in the model. 

15. Choose Volume as the variable and click OK to complete the definition. 

 

Create the Objective Function 
16. In the model tree open the Optimization Tasks, then Task-1 by clicking on the + button. 

Then double click Objective Functions. Abaqus/CAE will automatically open the Create 
Objective Function window. Name the response minimize_stress and click continue. 

17. Set the target response to Minimize the maximum design response values. 

18. Click in the Name box and select the design response DRESP_VM_stress. 

19. Accept all other defaults and click OK. 

Create the optimization Constraints 

20. In the model tree open the Optimization Tasks, then Task-1 by clicking on the + button. 
Then double click Constraints. Abaqus/CAE will automatically open the Create 
Constraint window. Name the constraint volume_constraint and click continue. 

21. Use the dropdown to populate the design response name box with DRESP_Volume. 

22. Change the constraint response to A fraction of the initial value and set this to 1. 

23. Click OK to complete the constraint. 

Create the Geometric Restrictions 
24. In the model tree open the Optimization Tasks, then Task-1 by clicking on the + button. 

Then double click Geometric Restrictions. Abaqus/CAE will automatically open the 
Create Geometric Restriction window. Select Type Growth and click continue. 

25. Select the Sets button in the bottom right of the graphics pane, then select 
design_nodes and continue. 

26. For the Optimization Displacement, set both Maximum in shrink direction and 
Maximum in growth direction to 1 

27. Click OK to complete the restriction. 

Save the Abaqus/CAE database. 

Creating and submitting an Optimization job 
Next, you will create and submit an Optimization job to perform the optimization. 

To create and submit an analysis job: 

1. Switch to the Job module and from the main menu select Optimization > Create. 
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2. In the dialog box, name the job ShapeOpt and select the model 
optimize_lug_mm_surface and the Task Task-1. 

3. In the Description field of the Edit Job dialog box, enter Workshop 3 – shape 
optimization. 

4. Click the Parallelization tab to use multiple processors and set the number to 4. Click 
OK to complete the process definition. 

5. From the menu toolbar select Optimization > Submit > ShapeOpt. 

The optimization process begins. 

6. From the main menu select Optimization > Monitor > ShapeOpt. to review progress 
with the optimization process. As the job runs the status will be shown in the monitor 
window. 

Viewing the optimization results 
You are now ready to view the results of the optimization in the Visualization module. 

1. In the Model Tree, click mouse button 3 on the optimization process ShapeOpt and 
select Combine from the menu that appears. Abaqus/CAE opens the Combine 
Optimization Results window. Note the location of the results directory and note and 
accept all other default settings. Click submit to combine the results of all the individual 
optimization analyses. Then Close the window. 

2. In the Model Tree, click mouse button 3 on the optimization process ShapeOpt and 
select Results from the menu that appears. Abaqus/CAE switches to the Visualization 
module and displays the optimized topology of the lug 

 

Toggle between Design Cycle 0 

 
 

and Design Cycle 10 to review the increase in thickness of the cross members with the 
subsequent decrease in vonMises stress. 
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You will now extract a smoothed surface from this optimization to work with in a new 
Abaqus/CAE database. 

 
1. Switch back to the Job module and select Optimization > Manager from the main 

menu. Highlight the ShapeOpt process and select Extract. 

2. Abaqus/CAE displays the Extract Surface Mesh Options dialogue box. Name the 
output ShapeOpt_surface; select Abaqus input file for format and use the output from 
the last design cycle (10). Then click Extract to generate the input deck 
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(ShapeOpt_surface.inp) of the surface. Note the location of the file in the message 
area. 

 

You have now completed Workshop 3. 

 


